VisiLogic 8.6.1 

New Hardware Support
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New Vision controllers
V350-33-TR6 and V130-33-TR6  8 Digital ( configurable via wiring to include 2 Analog (current/voltage) and 1 HSC/Shaft-encoder), 4 Analog Inputs (current), 6 Relay Outputs, 2 high-speed npn Transistor Outputs
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New Snap-in Modules
- V200-18-E46B  18 Digital (including 2 shaft encoders), 9 Analog Inputs 15 Relay 2 pnp/npn HSO, 2 Analog Outputs
- V200-18-E62B  30 Digital (including 2 shaft encoders), 2 Analog Inputs 15 Relay 28 pnp, 2 pnp/npn HSO, 2 Analog Outputs
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VisiLogic Menu Changes
As a result of screen size and resolution, some users have been unable to view the entire VisiLogic menu. This release includes a new menu 'Utils'.
Utils comprises the following menus: HMI, Alarms, Clock, Immediate, Debug, Idle, and Backup Security.
· New HMI Feature: HMI Element Default Setting
You can now set default settings for attributes such as Foreground and Background.

This can be applied from project properties( colors tab or from the HMI element itself. 
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New Save Trends to SD feature (enhanced only)
Using the Start and Stop Saving Trend to SD now appends data to a single .utr file. In addition, new SBs 117-118 enable you to display .utr segments on the HMI Display.
Note that previous to this version, using the Start and Stop Saving Trend to SD functions recorded a single, unsegmented .utr file. If the function Stop Recording Trend was used to pause the recording, when Start Saving was again activated, the function automatically overwrote the .utr file of the same name. 
To revert to the previous functionality, and overwrite the .utr file, set SB 116, SD Trends to SD: Set to Overwrite .utr. 
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Built-in Web Server: there have been a number of improvements, including a new Memory Allocation Compile button built into the Web Server Configurator.til
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OS Download: this can now be performed via RS485.
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String Library, .csv import: is no longer dependant on Microsoft Office being installed on the PC.

· CANbus baudrate: now supports 10kbps.

· Improved Email function GUI.

· Improved PID captions & description in PID Ladder menus.

· Updated message – When trying to open Visilogic version which has not been registered – Detailed message will appear.

· Compilation Errors:

· “Compiled STL code reached the maximum size” changed to “subroutine ladder code size exceeds limit – Split subroutine to solve problem”.

·  “Buffer full” messages changed to more detailed messages in order to guide the user how to solve the error.

· SMS Send - Compile error when there is no phone number and last received number.

· If HMI element exceeds size limit – “The HMI Element variable XXX exceeds the size limit”

· Loadcell – if hardware status messages and FB loadcell config status messages are linked to the same operand – compilation error.

· Delete phone numbers  from SMS phone book.

· Examples: New examples available
VisiLogic 8.6.0

This is a partial list of features in this version

New Hardware Support 

· New Vision models: V130-33-TA24, V35033-TA24
12 Digital Inputs, configurable via wiring to include 2 Analog, 2 PT100/TC, and 1 HSC/Shaft-encoder Input
10 Transistor Outputs, 2 Analog Outputs
· New Snap-in Module: V200-18-E46B
18 Digital, 9 Analog Inputs, 15 Relay , 2 pnp/npn, 2 Analog Outputs
· Modem: 
Wavecom  FASTRACK SUPREME

 

Hardware Documentation
In versions previous to 8.6.0, installing VisiLogic also installed a Hardware Documentation library. This library is now available as a separate download from http://unitronics.com/Content.aspx?page=Downloads

New methods for creating compressed data files
 These include PLC Clone files *.cxx, *.vxx), files for UniDownloader (*.dvi, *.vdf ), and  HMI cache files (*.urc, *.ura). 

New Ladder functions

SD

· Cloning
Use Ladder functions, Information mode, or VisiLogic Project files to clone a complete PLC and application, Data Tables, or operand values from a PLC or install such clone files to a PLC of the same model. 
Via SD Card Explorer, you can also remotely transfer these files from a PLC's SD card to PC, and from PC to PLC--Remote 'no-hands' PLC cloning.

· Safely Remove SD Card
Use this to check when the card may be safely removed.

· email attachments
Enhanced Vision controllers with SD cards enable you to email an attached file located on the SD card.

COM

· SNMP Trap

· SNMP Community Name

· DNS Resolver

· Telegram Parser

 

Data Tables

· Delete Rows

 

Utilities

· String Library
Import/Export .csv
· Data Tables
Import/Export .csv
· Information Mode
Now offers a built-in CANbus 'sniffer' in addition to the existing ones for Ethernet and serial communications.
· Project Optimizer
Run the Optimizer to view a list possible improvements that you can make in your project. In the results window, double click a line to jump to the appropriate location in the project.

· Built-in Web Server
A number of improvements make the Web Server easy to use.
· Enhanced Digital Signatures  (now supported by Enhanced models)
A number of additions enable Vision PLCs to meet standards in niche industries such as pharmaceuticals.
International Keypads (Enhanced Touch-screen only)

You can select a keyboard in a different language for Keypad Entry Variables in the Font Handler.

HMI Tweaks: Improving the user experience

· Netbook support
Scroll bars now enable the user to view the HMI Editor when working on small-screen netbooks.
· Project Navigator
Access Hardware Configuration, String Library, and WebServer from the navigation tree.
· Password Variable
Now supports Display text from String Library (Enhanced Vision only)
· HMI Display Bit
Turns ON when a Display is on-screen. The selected bit is now shown in View> HMI Information

 

CANbus SAE J1939 

Officially released from Beta. J1939 is currently running in installations across the globe.

 

Previous Versions

VisiLogic 8.02: What's New?
CanLayer2 ScanEX, new function
Scan_Ex enables you to receive all CANbus messages from devices via CAN Layer 2.

SB 108 Press "Enter" 1x (V130)
Normally, when a user enters a Keypad Entry value on a V130 HMI, the user must press the Enter button twice: 

· Once to 'approve' the value 

· Once to jump to and activate the next variable.

You can control this by turning both SB 76 and SB 108 ON in your application. Note that the user can press ESC to exit keypad entry mode.

VisiLogic 8.01: SD Suite Software 
SD Cards: New Ladder Functions (Enhanced only) 
	SD Password
	Guards SD data.

	Folder Report
	Reports the number of files currently in an SD folder, and the number of files can still be created in that folder.

	SD to/from Data Table
	Use these to read and write data between Data Tables and SD card.

	SD Trend
	Record an entire or partial trend to a .utr file in the SD card Trends folder.

Display Trend directly from a .utr file via HMI element Trend from SD.

	SD Excel
	Pull numeric data or text strings from the PLC and use delimiters to structure a line; then create an Excel file on an SD Card. Supports .csv & .txt lines

	Data Blocks
	Create, and then read/write PLC data to storage areas in the SdBLocks folder on a SD card.

SD Data Blocks may reach a total of 4G.

	Data Files
	Use Windows Explorer to store any type of file onto an SD card, such as .html or .jpg. Via Ladder, read and write these files in 'chunks' of 512 bytes.

You can also use these functions to pull data from the PLC and create files on the SD card.


SD Cards: New HMI Features (Enhanced only) 
	SD Card Browser
	Via an HMI button, display the contents of an SD folder, enable users to delete and execute files.

	Trend from SD
	This is a new HMI variable in the Graphs menu.


 

String Library: Store Strings in 16 libraries 

·  String Libraries have been increased to 16, making it easy to create a single application that can serve end-users in 16 languages.

· Strings can be imported/exported from/to Excel.

Both of the above features are in String Library> File

· Find Unreferenced Strings is a new tool on the String Library toolbar.

 

Complex Web Server (Enhanced, TCP/IP) 

Build your web pages using an HTML editor. Download them to an SD card in an Enhanced Vision running Enhanced PLC Webserver.vlp. available from:
http://www.unitronics.com/data/uploads/communication/WebServer.zip

The Vision can host pages with a variety of colors, fonts, links to other sites, and scripts. The controller must comprise a TCP/IP port, and must be connected to an Ethernet network.

New Hardware Support 

· Vision570 + onboard I/Os 
Vision V570-57-T34 OPLCs belong to the Color Vision Series, comprising a 5.7” touchscreen (this model will be released to market shortly)

· XL I/O Expansion Modules
XL I/O modules comprise enhanced I/O configurations and detachable I/O connectors. In addition, some modules comprise a built-in adapter for communicating with the PLC and providing power to the other expansion modules in the system.

 

Ladder Function: Frequency Measurement 
New Ladder function on the Immediate menu enables you measure High-speed Input frequency  with resolution and accuracy of 0.01 Hz.

SAE J1939 CANbus Protocol, CANbus modes 

If your Vision comprises a CANbus port, you can use:

· SAE J1939: Configure, then Send/Receive PGNs. Located on
COM> J1939.

· CANopen + CANLayer2: now available as simultaneous modes as option in COM Init.

· New Ladder Element: Map Register bytes can aid in managing CANOpen messages, reordering, expanding, and distributing.

New Ethernet features 

New functions available on the COM TCP/IP menu are:

· Ping
· Email>SMTP Mail Authentication

· SNMP(slave)
Built-in Web Server (Enhanced,TCP/IP)
· Advanced Options enable user logo, and logo via external link.

· New option ‘Editable’ enable user to send value to PLC via web interface

 

DF1 Slave 

Enables Vision to be slave to the DF1 AB protocol, COM >DF1
Data Tables 
New Ladder functions on the Data Tables menu:

· Copy a Data Table Row to Operand Vector.

· Copy a Vector of Operands to a Data Table Row.

Alarms 

Up to 16 Alarms are now supported by V130, and 14 are supported in History.

OEM: Image Customization 
You can replace Unitronics proprietary system images in your application, by using the utility Project> System Images. Among the images you can replace are:

· Information Mode: replace the Unitronics logo

· System Busy: replace the VisiLogic image

· Start-up Splash screen: replace the DOS-style screen

New Ladder Tools 
·  Advanced Find and Replace: Edit> Replace Operand now supports Replace in HMI Displays.

·  Address Vector: when addressing an Operand, you can assign a vector of operands a name, and automatically assign consecutive numbers.

· Vector: Shift Left now supports MB, XB, and additional register types.

 

On-line Test Mode 
Go to HMI Screen: when you are in Test mode, you can jump the VisiLogic application to the display that you see on the controller’s HMI screen by clicking the HMI icon on the Test toolbar

HMI Variable Features (Color Division) 

· Select Touch keyboard type: Select this when creating a Keypad Entry Variable.

· Numeric Variable-Range: You can now change colors according to range of values.

· Display Background –Image: Right-click a display, and select a background image.

· Graphical button: You can now select an image when creating a button.

 

HMI Improvements 

Text: when you create/edit a text box, there are new Alignment options; in addition, older options work in accordance with expected standards.

Fixed Issue: Vista .emf 
This format can now be viewed when running Vista

What's New? 

SD Cards : a new approach 

VisiLogic 7.01: What's New? 

Note that in order to use new version features you must download the latest OS, via the menu Connection> Communication & OS> Operating System tab.

Some of the information below refers to Vision Divisions . These are:

· Standard Vision: V120, V230, V260, V280, V290-BW, and V530

· Enhanced Vision: V570, V350, and V130

New SD functions enable you to save Trends

Remote Access Zoom 

You can now view an HMI screen at 1,2,3,4 times its size, or zoom it to fill your PC display.

Web Server (Enhanced only, supporting TCP/IP) 

Enriched web interface, now supports logos.

CANbus: Run Simultaneous modes 

In addition to CANopen + UniCAN, you can now run CANopen + CANbus, Layer 2 by selecting the relevant CANbus option in the COM Init function (Enhanced Vision only).

New Ladder Functions

Immediate: HSC Frequency Measurement Utilities 

Version 7.00: What's New? 

VisiLogic 7.0.0

Note that in order to use new version features you must download the latest OS, via the menu Connection> Communication & OS> Operating System tab.

Please note that not all features are documented.

Note that some of the information below refers to Vision Divisions . These are:

· Standard Vision: V120, V230, V260, V280, V290-BW, and V530

· Enhanced Vision: V570, V350, and V130

    Vision350--Palm-size PLC with COLOR 
	
	Vision350 OPLCs belong to the Color Vision Series, comprising a 3.5” TFT touchscreen that can show over 1000 displays; with a 3.5MB capacity for images & fonts.

7 models are currently available, each with a different on-board I/O configuration which may include PT100/TC and analog outputs. Via local and remote I/O Expansion Modules, V350 can support up to 512 I/Os. Additional features include:

Built-in operating panel containing an LCD and a keypad ♦ 1 built-in serial port: RS232/RS485 ♦ Optional: the user may order and install additional ports: RS232/RS485/Ethernet and CANbus ♦ SD card support


    Remote I/O (all models supporting CANbus) 
The EX-RC1 remote I/O module adapter enables you to distribute I/O Expansion Modules throughout your system. The adapter is connected to a master PLC by UniCAN, Unitronics’ proprietary CANbus protocol, and functions as a slave device within that network. Each adapter may be connected to up to 8 I/O expansion modules. Up to 512 I/Os may be connected to a single controller, depending on the models you select.

Additional details regarding this new feature will soon be available.

    SD Cards: Removable Memory Storage (Enhanced only) 
Enhanced Vision controllers now support SD cards. The V570 supports standard SD cards; V130 and V350 support micro SD cards. You can:

· Enable a VisiLogic application to store complete Data Tables, and to log Data Table rows to an SD card

· Import data on a SD card into Data Tables via VisiLogic

· Apply a password to prevent programs being uploaded from the controller to an SD card

· Store Alarms History on SD

· Use Information Mode to:
- Upload a VisiLogic application and OS firmware onto an SD card, and then copy them into other controllers
- Upload the entire Data Table structure of a controller

· Use Unitronics SD Tools utility, located on the VisiLogic Tools  menu, to:
- Convert and view the data on the SD card via PC
- Export that data to Excel or as an .csv file

· 'Clone' a PLC application.

    Send e-mail (all models supporting TCP/IP) 
This function enables a controller to send an email in response to Ladder conditions. In order to send email, the controller must comprise a TCP/IP port, and must be connected to an Ethernet network with access to an SMTP or ESMTP server.

Web Server (Enhanced only, supporting TCP/IP) 

Enhanced Vision controllers can act as servers and host web pages that can display operand values including timers and counters, and Alarm warnings. The controller must comprise a TCP/IP port, and must be connected to an Ethernet network.

Trends HMI Variable: New Feature (Enhanced only) 

· V130 support
Up to 4 Trends, each holding 2 Curves
· Y-axis value
The minimum and maximum value can now be linked to MI, enabling the value to be entered via keypad
· Remote Access
You can now view Trends in Remote Access
 

Information Mode: Additions for V130 

· View CANbus settings

· See connected I/O Expansion Modules

· View the PLC Name

· Monitor Ethernet communications as they flow through the port

1.25 mS Interrupt Routine (Enhanced only) 

This function is supported by Enhanced Vision models only. The 1.25 mS is called by naming a subroutine _Interrupt 1.25 mS. It functions exactly like the 2.5mS Interrupt routine.

New Stop Mode Subroutine (All models) 

If you include a subroutine named: 
_RUN_TO_STOP_
this subroutine will run a single time when the PLC enters Stop mode. Note the addition of a new related system operand SB 301, which turns on for a single cycle when the PLC goes into stop mode

New Boot Mode Features (Enhanced only) 

The OS version released with VisiLogic 7.00 also adds new Boot Mode features

· OS Download
an OS via COM2, Ethernet, or CANbus.

· Boot Info Mode: This gives you the ability to check software and certain hardware versions, view and edit Unit ID as well as certain CANbus, serial, and Ethernet settings. You enter this mode just like standard Information mode: when you are in Boot mode, touch ( or in the case of the V130 hold down the <I> key) for 7 seconds.

Stepper via High-speed Output (V570 only) 

Snap-in I/O modules offer high-speed outputs. If you are using a V570 with any model Snap-in I/O module, VisiLogic 7.00 or higher and the relevant OS, you can use these outputs to control stepper motors.

Note that any acceleration and deceleration that is needed to arrive at Target safely and accurately must be implemented via Ladder.

Import/Export Displays 

You can export displays and save them as .vld files, then import them into other projects.

HMI Variable Features (Enhanced/Color Division) 

· Password: you can now display text in the password variable

· Numeric Variables: can now display MF values

· Binary Text, List of Texts: supports background color, text from String Library

· List of Texts, Range of Texts: you can now determine background and foreground colors, and apply them to all rows

· List of Images: Select groups of images; when in the Select Image box, by holding down the Ctrl button and clicking images

· Project>Properties>Colors: you can select default colors for:
-Buttons: Pressed/Unpressed states
-Focus and Focus Text
-Default Line color

    UniDownloader 
The UniDownloader package enables you to build a complete, compressed project and send it anywhere to be installed in a PLC using a standalone downloader. Your end user will be able to download the application, but will not be able to view or modify it. The tool can download applications and OS.

The package comprises the UniDownload Designer, located on the Tools menu, and the UniDownloader, available as a separate download from www.unitronics.com.

    UniEDS 
Use the UniEDS to open CANopen EDS files. The utility is located on the Tools menu.

A additional Features (All models) 
· Struct: supports MI to Inputs

· UDP and TCP RAW functions are located on the COM>TCP/IP>UDP menu. Use them to send a vector of raw data to a remote Vision, broadcast the data to the entire network, or receive a stream of data and write it to a vector of registers.

· FB Protocol: now supports STX in checksum calculations

· New Function: Replace String

· Keystroke Ctrl + Z now undoes the last action

Additional Features (Enhanced only) 

· OS download via Ethernet

· Alarms: Supported in Remote Access

· Virtual Keypads: Enhanced Touchscreen Models
You can use SI 49 to change between three keypad types

· Relevant X Operand types are now supported in NUM to ASCII functions, and in the Events FB

· Color models only: Trend (Legacy) FB- you can write a value into SI 48 to change the color of the Trend as it is being drawn

    Issue: CANopen compatibility break 

	
	The CANopen System Operand addressing scheme changed as of VisiLogic version 7.00, OS 2.00 (Standard Division) OS 5.02 (Enhanced Division).

You can choose to continue editing older applications using previous VisiLogic versions contained in the VisiLogic Version Swapper. Note that in this case the controller must use an older OS.

However, if you choose to update the application and OS, note that you must change the system operands according to the following table.

System Integers

 

System Double Words

Old

New

24

7

200

211

25

8

201

212

26

56

202

213

28

57

203

214

 

 

204

215

 

 

205

216

 

 

206

217

 

 

207

218

 

 

208

219

 

 

240

220

 

 

241

221

 

 

242

222

 

 

243

223

 

 

244

224

 

 

245

225

 

 




 

Utilities

To see what updates have been released for Unitronics software utilities, such as DataXport, Remote Access and UniOPC Server, check http://www.unitronics.com/Content.aspx?page=Downloads .

VisiLogic Application Examples 

	When you install VisiLogic, an Examples folder is created on your hard disk, containing field-tested VisiLogic (.vlp) sample applications. You can copy these sample applications and adapt them for your own use--if, for example, an application is written for the V120, you can select the V230 via Hardware Configuration.
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